visualization through Trackster on local Galaxy installation

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

visualization through Trackster on local Galaxy installation

Yupu Liang
Hi,

I am trying to set up the visualization functionality on our local Galaxy installation. I followed the instructions on  https://wiki.galaxyproject.org/Visualization%20Setup

And here is the list of len files:
ls -l tool-data/shared/ucsc/chrom/
total 200
-rw-rw-r-- 1 galaxy galaxy    10 Jan 27 15:13 centromeres1.len
-rw-rw-r-- 1 galaxy galaxy   821 Jan 27 15:13 hg15.len
-rw-rw-r-- 1 galaxy galaxy   713 Jan 27 15:13 hg16.len
-rw-rw-r-- 1 galaxy galaxy   792 Jan 27 15:13 hg17.len
-rw-rw-r-- 1 galaxy galaxy   855 Jan 27 15:13 hg18.len
-rw-rw-r-- 1 galaxy galaxy   202 Jan 27 15:13 hg19Haps.len
-rwxr-xr-x 1 galaxy galaxy  1971 Jan 27 15:13 hg19.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hg19LggInv.len
-rw-rw-r-- 1 galaxy galaxy  4516 Jan 27 15:13 hg19Patch10.len
-rw-rw-r-- 1 galaxy galaxy  1983 Jan 27 15:13 hg19Patch2.len
-rw-rw-r-- 1 galaxy galaxy  2844 Jan 27 15:13 hg19Patch5.len
-rw-rw-r-- 1 galaxy galaxy  3879 Jan 27 15:13 hg19Patch9.len
-rw-rw-r-- 1 galaxy galaxy 11672 Jan 27 15:13 hg38.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef1.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef2.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef3.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase0.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase1.len
-rw-rw-r-- 1 galaxy galaxy 12697 Jan 27 15:13 repeats2.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHuman.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHumanMammal.len
-rw-rw-r-- 1 galaxy galaxy   362 Jan 27 15:13 venter1.len


When I test the visualization through Trackster. I got the following error after seeing a message saying "preparing the data, this can take a while……":

Error: The requested genome file (tool-data/shared/ucsc/chrom/hg18.len) could not be opened. Exiting!
sort: write failed: standard output: Broken pipe
sort: write error
Couldn't open tool-data/shared/ucsc/chrom/hg18.len , No such file or directory.


It seems something else failed in the middle of visualization as I do have the hg18.len under the default path with the global reading permission……..

Does anybody have similar experience? Is there is way for me to debug?

Best,
Yupu
___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: visualization through Trackster on local Galaxy installation

Hans-Rudolf Hotz
Hi Yupu


Just double checking: Have you restarted your Galaxy server after adding
the len files?


Regards, Hans-Rudolf


On 01/28/2014 08:12 PM, Yupu Liang wrote:

> Hi,
>
> I am trying to set up the visualization functionality on our local Galaxy installation. I followed the instructions on  https://wiki.galaxyproject.org/Visualization%20Setup
>
> And here is the list of len files:
> ls -l tool-data/shared/ucsc/chrom/
> total 200
> -rw-rw-r-- 1 galaxy galaxy    10 Jan 27 15:13 centromeres1.len
> -rw-rw-r-- 1 galaxy galaxy   821 Jan 27 15:13 hg15.len
> -rw-rw-r-- 1 galaxy galaxy   713 Jan 27 15:13 hg16.len
> -rw-rw-r-- 1 galaxy galaxy   792 Jan 27 15:13 hg17.len
> -rw-rw-r-- 1 galaxy galaxy   855 Jan 27 15:13 hg18.len
> -rw-rw-r-- 1 galaxy galaxy   202 Jan 27 15:13 hg19Haps.len
> -rwxr-xr-x 1 galaxy galaxy  1971 Jan 27 15:13 hg19.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hg19LggInv.len
> -rw-rw-r-- 1 galaxy galaxy  4516 Jan 27 15:13 hg19Patch10.len
> -rw-rw-r-- 1 galaxy galaxy  1983 Jan 27 15:13 hg19Patch2.len
> -rw-rw-r-- 1 galaxy galaxy  2844 Jan 27 15:13 hg19Patch5.len
> -rw-rw-r-- 1 galaxy galaxy  3879 Jan 27 15:13 hg19Patch9.len
> -rw-rw-r-- 1 galaxy galaxy 11672 Jan 27 15:13 hg38.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef1.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef2.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef3.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase0.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase1.len
> -rw-rw-r-- 1 galaxy galaxy 12697 Jan 27 15:13 repeats2.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHuman.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHumanMammal.len
> -rw-rw-r-- 1 galaxy galaxy   362 Jan 27 15:13 venter1.len
>
>
> When I test the visualization through Trackster. I got the following error after seeing a message saying "preparing the data, this can take a while……":
>
> Error: The requested genome file (tool-data/shared/ucsc/chrom/hg18.len) could not be opened. Exiting!
> sort: write failed: standard output: Broken pipe
> sort: write error
> Couldn't open tool-data/shared/ucsc/chrom/hg18.len , No such file or directory.
>
>
> It seems something else failed in the middle of visualization as I do have the hg18.len under the default path with the global reading permission……..
>
> Does anybody have similar experience? Is there is way for me to debug?
>
> Best,
> Yupu
> ___________________________________________________________
> The Galaxy User list should be used for the discussion of
> Galaxy analysis and other features on the public server
> at usegalaxy.org.  Please keep all replies on the list by
> using "reply all" in your mail client.  For discussion of
> local Galaxy instances and the Galaxy source code, please
> use the Galaxy Development list:
>
>    http://lists.bx.psu.edu/listinfo/galaxy-dev
>
> To manage your subscriptions to this and other Galaxy lists,
> please use the interface at:
>
>    http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>
>    http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: visualization through Trackster on local Galaxy installation

Yupu Liang
Yes I have restarted my Galaxy many times and I have also tried different genome build such as hg18 and experience the same problem.

Yupu
On Jan 29, 2014, at 3:32, Hans-Rudolf Hotz <[hidden email]> wrote:

> Hi Yupu
>
>
> Just double checking: Have you restarted your Galaxy server after adding the len files?
>
>
> Regards, Hans-Rudolf
>
>
> On 01/28/2014 08:12 PM, Yupu Liang wrote:
>> Hi,
>>
>> I am trying to set up the visualization functionality on our local Galaxy installation. I followed the instructions on  https://wiki.galaxyproject.org/Visualization%20Setup
>>
>> And here is the list of len files:
>> ls -l tool-data/shared/ucsc/chrom/
>> total 200
>> -rw-rw-r-- 1 galaxy galaxy    10 Jan 27 15:13 centromeres1.len
>> -rw-rw-r-- 1 galaxy galaxy   821 Jan 27 15:13 hg15.len
>> -rw-rw-r-- 1 galaxy galaxy   713 Jan 27 15:13 hg16.len
>> -rw-rw-r-- 1 galaxy galaxy   792 Jan 27 15:13 hg17.len
>> -rw-rw-r-- 1 galaxy galaxy   855 Jan 27 15:13 hg18.len
>> -rw-rw-r-- 1 galaxy galaxy   202 Jan 27 15:13 hg19Haps.len
>> -rwxr-xr-x 1 galaxy galaxy  1971 Jan 27 15:13 hg19.len
>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hg19LggInv.len
>> -rw-rw-r-- 1 galaxy galaxy  4516 Jan 27 15:13 hg19Patch10.len
>> -rw-rw-r-- 1 galaxy galaxy  1983 Jan 27 15:13 hg19Patch2.len
>> -rw-rw-r-- 1 galaxy galaxy  2844 Jan 27 15:13 hg19Patch5.len
>> -rw-rw-r-- 1 galaxy galaxy  3879 Jan 27 15:13 hg19Patch9.len
>> -rw-rw-r-- 1 galaxy galaxy 11672 Jan 27 15:13 hg38.len
>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef1.len
>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef2.len
>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef3.len
>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase0.len
>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase1.len
>> -rw-rw-r-- 1 galaxy galaxy 12697 Jan 27 15:13 repeats2.len
>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHuman.len
>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHumanMammal.len
>> -rw-rw-r-- 1 galaxy galaxy   362 Jan 27 15:13 venter1.len
>>
>>
>> When I test the visualization through Trackster. I got the following error after seeing a message saying "preparing the data, this can take a while……":
>>
>> Error: The requested genome file (tool-data/shared/ucsc/chrom/hg18.len) could not be opened. Exiting!
>> sort: write failed: standard output: Broken pipe
>> sort: write error
>> Couldn't open tool-data/shared/ucsc/chrom/hg18.len , No such file or directory.
>>
>>
>> It seems something else failed in the middle of visualization as I do have the hg18.len under the default path with the global reading permission……..
>>
>> Does anybody have similar experience? Is there is way for me to debug?
>>
>> Best,
>> Yupu
>> ___________________________________________________________
>> The Galaxy User list should be used for the discussion of
>> Galaxy analysis and other features on the public server
>> at usegalaxy.org.  Please keep all replies on the list by
>> using "reply all" in your mail client.  For discussion of
>> local Galaxy instances and the Galaxy source code, please
>> use the Galaxy Development list:
>>
>>   http://lists.bx.psu.edu/listinfo/galaxy-dev
>>
>> To manage your subscriptions to this and other Galaxy lists,
>> please use the interface at:
>>
>>   http://lists.bx.psu.edu/
>>
>> To search Galaxy mailing lists use the unified search at:
>>
>>   http://galaxyproject.org/search/mailinglists/
>>


___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: visualization through Trackster on local Galaxy installation

Jen Hillman-Jackson
In reply to this post by Yupu Liang
Hello Yupu,

Using a .len file is problematic at this time. In the upcoming release
this will be corrected. Using a .fasta file is the solution. In many
cases, using a .fasta file can be preferred as it will include the
reference genome sequence in the visualization, but the choice is yours,
once the correction is released to the distribution.

More about this is in a recent post from Jeremy:
http://lists.bx.psu.edu/pipermail/galaxy-user/2014-January/007106.html

Our apologies for the confusion this caused. The advice from Hans-Rudolf
is under normal circumstances the best first-pass route for
troubleshooting, and you will want to restart after using the fasta
method as well.

Best,

Jen
Galaxy team

On 1/28/14 11:12 AM, Yupu Liang wrote:

> Hi,
>
> I am trying to set up the visualization functionality on our local Galaxy installation. I followed the instructions on  https://wiki.galaxyproject.org/Visualization%20Setup
>
> And here is the list of len files:
> ls -l tool-data/shared/ucsc/chrom/
> total 200
> -rw-rw-r-- 1 galaxy galaxy    10 Jan 27 15:13 centromeres1.len
> -rw-rw-r-- 1 galaxy galaxy   821 Jan 27 15:13 hg15.len
> -rw-rw-r-- 1 galaxy galaxy   713 Jan 27 15:13 hg16.len
> -rw-rw-r-- 1 galaxy galaxy   792 Jan 27 15:13 hg17.len
> -rw-rw-r-- 1 galaxy galaxy   855 Jan 27 15:13 hg18.len
> -rw-rw-r-- 1 galaxy galaxy   202 Jan 27 15:13 hg19Haps.len
> -rwxr-xr-x 1 galaxy galaxy  1971 Jan 27 15:13 hg19.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hg19LggInv.len
> -rw-rw-r-- 1 galaxy galaxy  4516 Jan 27 15:13 hg19Patch10.len
> -rw-rw-r-- 1 galaxy galaxy  1983 Jan 27 15:13 hg19Patch2.len
> -rw-rw-r-- 1 galaxy galaxy  2844 Jan 27 15:13 hg19Patch5.len
> -rw-rw-r-- 1 galaxy galaxy  3879 Jan 27 15:13 hg19Patch9.len
> -rw-rw-r-- 1 galaxy galaxy 11672 Jan 27 15:13 hg38.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef1.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef2.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef3.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase0.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase1.len
> -rw-rw-r-- 1 galaxy galaxy 12697 Jan 27 15:13 repeats2.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHuman.len
> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHumanMammal.len
> -rw-rw-r-- 1 galaxy galaxy   362 Jan 27 15:13 venter1.len
>
>
> When I test the visualization through Trackster. I got the following error after seeing a message saying "preparing the data, this can take a while……":
>
> Error: The requested genome file (tool-data/shared/ucsc/chrom/hg18.len) could not be opened. Exiting!
> sort: write failed: standard output: Broken pipe
> sort: write error
> Couldn't open tool-data/shared/ucsc/chrom/hg18.len , No such file or directory.
>
>
> It seems something else failed in the middle of visualization as I do have the hg18.len under the default path with the global reading permission……..
>
> Does anybody have similar experience? Is there is way for me to debug?
>
> Best,
> Yupu
> ___________________________________________________________
> The Galaxy User list should be used for the discussion of
> Galaxy analysis and other features on the public server
> at usegalaxy.org.  Please keep all replies on the list by
> using "reply all" in your mail client.  For discussion of
> local Galaxy instances and the Galaxy source code, please
> use the Galaxy Development list:
>
>    http://lists.bx.psu.edu/listinfo/galaxy-dev
>
> To manage your subscriptions to this and other Galaxy lists,
> please use the interface at:
>
>    http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>
>    http://galaxyproject.org/search/mailinglists/
>

--
Jennifer Hillman-Jackson
http://galaxyproject.org

___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

  http://galaxyproject.org/search/mailinglists/
Jennifer Hillman-Jackson
http://galaxyproject.org
Reply | Threaded
Open this post in threaded view
|

Re: visualization through Trackster on local Galaxy installation

Jen Hillman-Jackson
Hi Yupu,

I'm sorry, I mixed up the processing for custom builds with the
processing for installed builds in my initial reply. A .2bit & .len file
are appropriate for what you are doing - and the wiki instructions are
accurate.

Still, I double checked with Jeremy, the scientist that developed the
tool, about your issue. He found that the full path to the .len file
needs to be specified right now in order for installed builds to
function correctly.

This deviates from the wiki instructions, but we consider this a bug and
plan to correct it in the next release.

Please try using the full path and let us know how that works out,

Jen
Galaxy team

On 1/29/14 11:54 AM, Yupu Liang wrote:

> Dear Jennifer:
>
> Hi, I did put 2bit file as suggested by https://wiki.galaxyproject.org/Visualization%20Setup.
>
> Should I get rid of the len file?  and I assume I will also need to take off the len_file_path out of the universe_wsgi.ini file.
>
> In term of using .fasta file. I have them and I am not clear where I should put them for visualization purpose and also what adjustment i need to make in the ini file. Any help would be appreciated and I am really excited about doing all the visualization within Galaxy. I think the biologists would really love these features.
>
> Thanks a lot,
> Yupu
>
>
>
>
> On Jan 29, 2014, at 14:21, Jennifer Jackson <[hidden email]> wrote:
>
>> Hello Yupu,
>>
>> Using a .len file is problematic at this time. In the upcoming release this will be corrected. Using a .fasta file is the solution. In many cases, using a .fasta file can be preferred as it will include the reference genome sequence in the visualization, but the choice is yours, once the correction is released to the distribution.
>>
>> More about this is in a recent post from Jeremy:
>> http://lists.bx.psu.edu/pipermail/galaxy-user/2014-January/007106.html
>>
>> Our apologies for the confusion this caused. The advice from Hans-Rudolf is under normal circumstances the best first-pass route for troubleshooting, and you will want to restart after using the fasta method as well.
>>
>> Best,
>>
>> Jen
>> Galaxy team
>>
>> On 1/28/14 11:12 AM, Yupu Liang wrote:
>>> Hi,
>>>
>>> I am trying to set up the visualization functionality on our local Galaxy installation. I followed the instructions on  https://wiki.galaxyproject.org/Visualization%20Setup
>>>
>>> And here is the list of len files:
>>> ls -l tool-data/shared/ucsc/chrom/
>>> total 200
>>> -rw-rw-r-- 1 galaxy galaxy    10 Jan 27 15:13 centromeres1.len
>>> -rw-rw-r-- 1 galaxy galaxy   821 Jan 27 15:13 hg15.len
>>> -rw-rw-r-- 1 galaxy galaxy   713 Jan 27 15:13 hg16.len
>>> -rw-rw-r-- 1 galaxy galaxy   792 Jan 27 15:13 hg17.len
>>> -rw-rw-r-- 1 galaxy galaxy   855 Jan 27 15:13 hg18.len
>>> -rw-rw-r-- 1 galaxy galaxy   202 Jan 27 15:13 hg19Haps.len
>>> -rwxr-xr-x 1 galaxy galaxy  1971 Jan 27 15:13 hg19.len
>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hg19LggInv.len
>>> -rw-rw-r-- 1 galaxy galaxy  4516 Jan 27 15:13 hg19Patch10.len
>>> -rw-rw-r-- 1 galaxy galaxy  1983 Jan 27 15:13 hg19Patch2.len
>>> -rw-rw-r-- 1 galaxy galaxy  2844 Jan 27 15:13 hg19Patch5.len
>>> -rw-rw-r-- 1 galaxy galaxy  3879 Jan 27 15:13 hg19Patch9.len
>>> -rw-rw-r-- 1 galaxy galaxy 11672 Jan 27 15:13 hg38.len
>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef1.len
>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef2.len
>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef3.len
>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase0.len
>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase1.len
>>> -rw-rw-r-- 1 galaxy galaxy 12697 Jan 27 15:13 repeats2.len
>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHuman.len
>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHumanMammal.len
>>> -rw-rw-r-- 1 galaxy galaxy   362 Jan 27 15:13 venter1.len
>>>
>>>
>>> When I test the visualization through Trackster. I got the following error after seeing a message saying "preparing the data, this can take a while……":
>>>
>>> Error: The requested genome file (tool-data/shared/ucsc/chrom/hg18.len) could not be opened. Exiting!
>>> sort: write failed: standard output: Broken pipe
>>> sort: write error
>>> Couldn't open tool-data/shared/ucsc/chrom/hg18.len , No such file or directory.
>>>
>>>
>>> It seems something else failed in the middle of visualization as I do have the hg18.len under the default path with the global reading permission……..
>>>
>>> Does anybody have similar experience? Is there is way for me to debug?
>>>
>>> Best,
>>> Yupu
>>> ___________________________________________________________
>>> The Galaxy User list should be used for the discussion of
>>> Galaxy analysis and other features on the public server
>>> at usegalaxy.org.  Please keep all replies on the list by
>>> using "reply all" in your mail client.  For discussion of
>>> local Galaxy instances and the Galaxy source code, please
>>> use the Galaxy Development list:
>>>
>>>    http://lists.bx.psu.edu/listinfo/galaxy-dev
>>>
>>> To manage your subscriptions to this and other Galaxy lists,
>>> please use the interface at:
>>>
>>>    http://lists.bx.psu.edu/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>>
>>>    http://galaxyproject.org/search/mailinglists/
>>>
>> --
>> Jennifer Hillman-Jackson
>> http://galaxyproject.org
>>
>

--
Jennifer Hillman-Jackson
http://galaxyproject.org

___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

  http://galaxyproject.org/search/mailinglists/
Jennifer Hillman-Jackson
http://galaxyproject.org
Reply | Threaded
Open this post in threaded view
|

Re: visualization through Trackster on local Galaxy installation

Yupu Liang
Using full path in the ini file fix the problem!

Thanks,
Yupu
On Jan 30, 2014, at 10:21, Jennifer Jackson <[hidden email]> wrote:

> Hi Yupu,
>
> I'm sorry, I mixed up the processing for custom builds with the processing for installed builds in my initial reply. A .2bit & .len file are appropriate for what you are doing - and the wiki instructions are accurate.
>
> Still, I double checked with Jeremy, the scientist that developed the tool, about your issue. He found that the full path to the .len file needs to be specified right now in order for installed builds to function correctly.
>
> This deviates from the wiki instructions, but we consider this a bug and plan to correct it in the next release.
>
> Please try using the full path and let us know how that works out,
>
> Jen
> Galaxy team
>
> On 1/29/14 11:54 AM, Yupu Liang wrote:
>> Dear Jennifer:
>>
>> Hi, I did put 2bit file as suggested by https://wiki.galaxyproject.org/Visualization%20Setup.
>>
>> Should I get rid of the len file?  and I assume I will also need to take off the len_file_path out of the universe_wsgi.ini file.
>>
>> In term of using .fasta file. I have them and I am not clear where I should put them for visualization purpose and also what adjustment i need to make in the ini file. Any help would be appreciated and I am really excited about doing all the visualization within Galaxy. I think the biologists would really love these features.
>>
>> Thanks a lot,
>> Yupu
>>
>>
>>
>>
>> On Jan 29, 2014, at 14:21, Jennifer Jackson <[hidden email]> wrote:
>>
>>> Hello Yupu,
>>>
>>> Using a .len file is problematic at this time. In the upcoming release this will be corrected. Using a .fasta file is the solution. In many cases, using a .fasta file can be preferred as it will include the reference genome sequence in the visualization, but the choice is yours, once the correction is released to the distribution.
>>>
>>> More about this is in a recent post from Jeremy:
>>> http://lists.bx.psu.edu/pipermail/galaxy-user/2014-January/007106.html
>>>
>>> Our apologies for the confusion this caused. The advice from Hans-Rudolf is under normal circumstances the best first-pass route for troubleshooting, and you will want to restart after using the fasta method as well.
>>>
>>> Best,
>>>
>>> Jen
>>> Galaxy team
>>>
>>> On 1/28/14 11:12 AM, Yupu Liang wrote:
>>>> Hi,
>>>>
>>>> I am trying to set up the visualization functionality on our local Galaxy installation. I followed the instructions on  https://wiki.galaxyproject.org/Visualization%20Setup
>>>>
>>>> And here is the list of len files:
>>>> ls -l tool-data/shared/ucsc/chrom/
>>>> total 200
>>>> -rw-rw-r-- 1 galaxy galaxy    10 Jan 27 15:13 centromeres1.len
>>>> -rw-rw-r-- 1 galaxy galaxy   821 Jan 27 15:13 hg15.len
>>>> -rw-rw-r-- 1 galaxy galaxy   713 Jan 27 15:13 hg16.len
>>>> -rw-rw-r-- 1 galaxy galaxy   792 Jan 27 15:13 hg17.len
>>>> -rw-rw-r-- 1 galaxy galaxy   855 Jan 27 15:13 hg18.len
>>>> -rw-rw-r-- 1 galaxy galaxy   202 Jan 27 15:13 hg19Haps.len
>>>> -rwxr-xr-x 1 galaxy galaxy  1971 Jan 27 15:13 hg19.len
>>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hg19LggInv.len
>>>> -rw-rw-r-- 1 galaxy galaxy  4516 Jan 27 15:13 hg19Patch10.len
>>>> -rw-rw-r-- 1 galaxy galaxy  1983 Jan 27 15:13 hg19Patch2.len
>>>> -rw-rw-r-- 1 galaxy galaxy  2844 Jan 27 15:13 hg19Patch5.len
>>>> -rw-rw-r-- 1 galaxy galaxy  3879 Jan 27 15:13 hg19Patch9.len
>>>> -rw-rw-r-- 1 galaxy galaxy 11672 Jan 27 15:13 hg38.len
>>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef1.len
>>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef2.len
>>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef3.len
>>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase0.len
>>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase1.len
>>>> -rw-rw-r-- 1 galaxy galaxy 12697 Jan 27 15:13 repeats2.len
>>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHuman.len
>>>> -rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHumanMammal.len
>>>> -rw-rw-r-- 1 galaxy galaxy   362 Jan 27 15:13 venter1.len
>>>>
>>>>
>>>> When I test the visualization through Trackster. I got the following error after seeing a message saying "preparing the data, this can take a while……":
>>>>
>>>> Error: The requested genome file (tool-data/shared/ucsc/chrom/hg18.len) could not be opened. Exiting!
>>>> sort: write failed: standard output: Broken pipe
>>>> sort: write error
>>>> Couldn't open tool-data/shared/ucsc/chrom/hg18.len , No such file or directory.
>>>>
>>>>
>>>> It seems something else failed in the middle of visualization as I do have the hg18.len under the default path with the global reading permission……..
>>>>
>>>> Does anybody have similar experience? Is there is way for me to debug?
>>>>
>>>> Best,
>>>> Yupu
>>>> ___________________________________________________________
>>>> The Galaxy User list should be used for the discussion of
>>>> Galaxy analysis and other features on the public server
>>>> at usegalaxy.org.  Please keep all replies on the list by
>>>> using "reply all" in your mail client.  For discussion of
>>>> local Galaxy instances and the Galaxy source code, please
>>>> use the Galaxy Development list:
>>>>
>>>>   http://lists.bx.psu.edu/listinfo/galaxy-dev
>>>>
>>>> To manage your subscriptions to this and other Galaxy lists,
>>>> please use the interface at:
>>>>
>>>>   http://lists.bx.psu.edu/
>>>>
>>>> To search Galaxy mailing lists use the unified search at:
>>>>
>>>>   http://galaxyproject.org/search/mailinglists/
>>>>
>>> --
>>> Jennifer Hillman-Jackson
>>> http://galaxyproject.org
>>>
>>
>
> --
> Jennifer Hillman-Jackson
> http://galaxyproject.org
>


___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: visualization through Trackster on local Galaxy installation

Jen Hillman-Jackson
Yupu,

Very glad! The thanks goes to Jeremy who sorted out the issue.

We had some big changes the last few release cycles, and unexpected
issues popped out. It was very nice of you to not only take the time to
report the problem, but to also follow up with sending feedback until
resolved.

If this is not corrected soon for some reason (as it is expected to be),
I will add a temporary note to the wiki instructions. But, mainling list
Q & A, like this conversation, will show up in our Galaxy custom
searches. So can certainly help others, just as it is, right now.

Thanks again, your patience and help confirming the work-around in a
local build (one not run by a team member) are very much appreciated!

Best,

Jen
Galaxy team

On 1/30/14 9:17 AM, Yupu Liang wrote:
> Using full path in the ini file fix the problem!
>
> Thanks,
> Yupu
> On Jan 30, 2014, at 10:21, Jennifer Jackson <[hidden email]> wrote:
>
>

--
Jennifer Hillman-Jackson
http://galaxyproject.org

___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

  http://galaxyproject.org/search/mailinglists/
Jennifer Hillman-Jackson
http://galaxyproject.org